NUS VPN on macOS Sierra? Update Pulse Secure to version 5.2r5.0-b869

With each version of OS X, it is necessary to update NUS VPN to access certain university sites remotely. This prevented me from using the macOS Sierra beta version as the VPN software would not be updated until stable release.

The Pulse Secure version that works in macOS sierra is 5.2r5.0-b869, which is available from NUS Computer Centre at

Screenshot 107

If you have updated your OS, you should go ahead and download this latest version.


Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s